cisco 实现动态vpn的一个例子

1450
  duplex auto
  speed auto
  !
  interface Dialer1
  ip address negotiated
  ip mtu 1492
  ip nat outside
  encapsulation ppp
  dialer pool 1
  dialer-group 1
  ppp pap sent-username ddd password 0 ddd
  crypto map pix
  !
  ip nat inside source
  route-map nonat interface D
  ialer1 overload
  
  ip classless
  ip route 0.0.0.0 0.0.0.0 Dialer1
  !
  no ip http server
  no ip http secure-server
  !
  !
  access-list 101 permit ip 168.98.1.0
  0.0.0.255 168.98.0.0 0.0.0.255
  
  access-list 110 deny
  ip 168.98.1.0 0.0.0.255 168
  .98.0.0 0.0.0.255
  
  access-list 110 permit ip 168.98.1.0
  0.0.0.255 any
  
  !
  route-map nonat permit 10
  match ip address 110
  !
  !
  !
  control-plane
  !
  !
  !
  !
  !
  !
  !
  !
  !
  line con 0
  line aux 0
  line vty 0 4
  password cisco
  login
  !
  !
  !
  end
  
  这是一个site to site 的vpn的实现,很多中国的企业,也在用软件的方式来实现这些功能,同时也支持移动用户的方式。
  一般来讲,就是在中心点(总部,同样可以是动态ip地址)安装一个vpn软件的服务器版本,然后在远端的lan上安装一个vpn 网关,移动用户安装vpn 移动客户端。
  但是感觉速度永远是一个瓶颈,大家自己衡量吧。

上一页  [1] [2] 

 
关键字:cisco 实现动态vpn的一个例子